Zu viel Arbeit für IRQ 11

Benutzer helfen Benutzern bei allem rund um Computer und das Internet

Moderator: Techies

Benutzeravatar
FENRIS
häufiger Besucher
Beiträge: 75
Registriert: Freitag 5. Mai 2006, 14:23
PLZ: 37351

Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von FENRIS » Sonntag 26. April 2009, 20:26

Habe ein Problem immer wenn ich den Rechner hochfahre bekomme ich die Nachricht:

too much work for IRQ 11:

cat /proc/interrupts zeigt mir folgendes an:

Code: Alles auswählen

CPU0       
  0:    1671781    XT-PIC-XT        timer
  1:       4441    XT-PIC-XT        i8042
  2:          0    XT-PIC-XT        cascade
  4:          1    XT-PIC-XT      
  5:     386971    XT-PIC-XT        ohci_hcd:usb1, ehci_hcd:usb3
  6:          5    XT-PIC-XT        floppy
  7:          1    XT-PIC-XT        parport0
  8:          1    XT-PIC-XT        rtc0
  9:          0    XT-PIC-XT        acpi
 10:          0    XT-PIC-XT        MPU401 UART
 11:     218886    XT-PIC-XT        ohci_hcd:usb2, SiS SI7012, eth0
 12:     627231    XT-PIC-XT        i8042
 14:      33044    XT-PIC-XT        ide0
 15:     108538    XT-PIC-XT        ide1
NMI:          0   Non-maskable interrupts
LOC:          0   Local timer interrupts
RES:          0   Rescheduling interrupts
CAL:          0   function call interrupts
TLB:          0   TLB shootdowns
TRM:          0   Thermal event interrupts
SPU:          0   Spurious interrupts
ERR:          0
MIS:          0
Ich habe mein Dikettenlaufwerk zwar noch drinne, aber das Strom und das IDE-Kabel abgemacht.

Wo und wie kann ich die Dreifachbelegung beseitigen?

LG FENRIS
"Fleischessen ist ein Überbleibsel der größten Rohheit. Der Übergang zum Vegetarismus ist die erste und natürlichste Folge der Aufklärung."

Lew Tolstoi

Benutzeravatar
niels
Site Admin
Beiträge: 2260
Registriert: Freitag 22. März 2002, 16:15
PLZ: 37075
voller Name: Niels Dettenbach
Wohnort: Göttingen
Kontaktdaten:

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von niels » Montag 27. April 2009, 06:40

Hallo Fenris,


hmm, schaut so aus, als ob dort USB und Ethernet auf dem IRQ liegen, was dem Gerät zuviel ist. Demnach mußt Du dem IRQ 11 Arbeit "abnehmen" bzw. woanders hin verlagern.

Falls Du USB-Geräte angesteckt hast, beim Booten mal abziehen - ebenso mögliche Ethernetkabel.

Soweit Dein Laptop-BIOS die händische Zuordnung von IRQs erlaubt (z.B. unter "PNP" - machen allerdings viele Notebooks nicht), "spiel" damit etwas herum.

ACPI und APIC beim Kernelstart testweise aus-/anmachen.

Code: Alles auswählen

Btw: ...vielleicht auch schon ein bischen älterer Rechner?
Schau mal im
http://tldp.org/HOWTO/Ethernet-HOWTO-7.html
(unten). Vielleicht hilft Dir das.

Je nach Gerät und Konfiguration kannst Du bestimmte Module / auch an bestimmte IRQs binden. Schau Dir deshalb mal die möglichen Optionen zu den o.g. modulen (z.B. mit "modinfo modulname" und die meist als "options" unter /etc/modules.d, /etc/modprobe.d/ bzw. *.conf) zu findenden Modul-/Treiberkonfigurationen an.

Ansonsten sollten die genannten Treibermodule auf IRQ 11 Optionen bieten, die man mal anschauen sollte.

Hilft Dir das bzw. ändert sich etwas?

Kannst Du weiter booten? Wenn ja, was sagt dmesg später? Kannst Du die Geräte (Netzwerk, USB) benutzen?

Niels
---
http://www.syndicat.com
Zuletzt geändert von niels am Montag 27. April 2009, 12:15, insgesamt 1-mal geändert.
Grund: ergänzt

Benutzeravatar
FENRIS
häufiger Besucher
Beiträge: 75
Registriert: Freitag 5. Mai 2006, 14:23
PLZ: 37351

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von FENRIS » Montag 27. April 2009, 20:07

Hallo Niels,

ich habe im BIOS mal den Diskettencontroller und die parallele Schnittstelle deaktiviert.

Leider war das Ergebnis wohl nicht so gut, es sind zwar IRQ frei geworden aber auf IRQ11 habe ich jetzt eine vierfachbelegung.

Code: Alles auswählen

         CPU0       
  0:      14244    XT-PIC-XT        timer
  1:         55    XT-PIC-XT        i8042
  2:          0    XT-PIC-XT        cascade
  4:          1    XT-PIC-XT      
  5:          4    XT-PIC-XT        ehci_hcd:usb3
  8:          0    XT-PIC-XT        rtc0
  9:          0    XT-PIC-XT        acpi
 10:          0    XT-PIC-XT        MPU401 UART
 11:        184    XT-PIC-XT        ohci_hcd:usb1, ohci_hcd:usb2, SiS SI7012, eth0
 12:       1811    XT-PIC-XT        i8042
 14:       6584    XT-PIC-XT        ide0
 15:        610    XT-PIC-XT        ide1
NMI:          0   Non-maskable interrupts
LOC:          0   Local timer interrupts
RES:          0   Rescheduling interrupts
CAL:          0   function call interrupts
TLB:          0   TLB shootdowns
TRM:          0   Thermal event interrupts
SPU:          0   Spurious interrupts
ERR:          0
MIS:          0
btw. Es handelt sich um einen älteren PC (Das BIOS ist von 2000). Die Ethernetkarte ist onBoard. Das Betriebssystem ist Debian Lenny 5.01.

Es handelt sich wohl um ein Plug an Play BIOS. Im Plug an Play Setup habe ich folgende Optionen:
Welche mir aber nichts sagen.

Plug and Play Aware O/S: YES NO
Primary Graphic Adapter: PCI AGP
Allocate IRQ to PCI VGA: YES NO
PCI IDE BusMaster: DISABLED ENABLED

Wo werden eigentlich die IRQ zu geteilt über das BIOS oder kann mensch da auch was über das OS machen.

LG Thomas
"Fleischessen ist ein Überbleibsel der größten Rohheit. Der Übergang zum Vegetarismus ist die erste und natürlichste Folge der Aufklärung."

Lew Tolstoi

Benutzeravatar
FENRIS
häufiger Besucher
Beiträge: 75
Registriert: Freitag 5. Mai 2006, 14:23
PLZ: 37351

Jetzt zu viel Arbeit für IRQ 5

Ungelesener Beitrag von FENRIS » Dienstag 28. April 2009, 13:20

Ich habe jetzt auch noch die serielle Schnittstelle deaktiviert.

Jetzt liegt die Ethernetkarte mit den 2 USB-Sachen auf Port 5.

Den PCI Busmater habe ich auch aktiviert, hatte im Internet gelesen, dass das einen Performance-Vorteil hat.
"Fleischessen ist ein Überbleibsel der größten Rohheit. Der Übergang zum Vegetarismus ist die erste und natürlichste Folge der Aufklärung."

Lew Tolstoi

Benutzeravatar
niels
Site Admin
Beiträge: 2260
Registriert: Freitag 22. März 2002, 16:15
PLZ: 37075
voller Name: Niels Dettenbach
Wohnort: Göttingen
Kontaktdaten:

Re: Jetzt zu viel Arbeit für IRQ 5

Ungelesener Beitrag von niels » Dienstag 28. April 2009, 13:51

FENRIS hat geschrieben:Ich habe jetzt auch noch die serielle Schnittstelle deaktiviert.
Jetzt liegt die Ethernetkarte mit den 2 USB-Sachen auf Port 5.
Das sollte das Problem demnach nicht beheben, da die Last nun einfach auf einem anderen IRQ liegt.

Was haben o.g. Massnahmen gebracht?
Hast Du Ethernet oder USB-Geräte angesteckt (dann mal abgezogen)?

Du solltest wohl versuchen die Ethernet-Karte oder USB-Host auf einen anderen IRQ zu bekommen (per BIOS oder softwareseitig) - nicht beides auf einmal ;)
FENRIS hat geschrieben:Den PCI Busmater habe ich auch aktiviert, hatte im Internet gelesen, dass das einen Performance-Vorteil hat.
Üblicherweise ja.

Benutzeravatar
FENRIS
häufiger Besucher
Beiträge: 75
Registriert: Freitag 5. Mai 2006, 14:23
PLZ: 37351

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von FENRIS » Dienstag 28. April 2009, 15:13

Ich habe alles mal vor dem Booten rausgezogen.

Aber es kommt das selbe wie vorher:

Code: Alles auswählen

           CPU0       
  0:      15981    XT-PIC-XT        timer
  1:        139    XT-PIC-XT        i8042
  2:          0    XT-PIC-XT        cascade
  5:          0    XT-PIC-XT        ohci_hcd:usb2, ehci_hcd:usb3, eth0
  8:          1    XT-PIC-XT        rtc0
  9:          0    XT-PIC-XT        acpi
 10:          0    XT-PIC-XT        MPU401 UART
 11:          0    XT-PIC-XT        ohci_hcd:usb1, SiS SI7012
 12:       1011    XT-PIC-XT        i8042
 14:       3954    XT-PIC-XT        ide0
 15:        790    XT-PIC-XT        ide1
NMI:          0   Non-maskable interrupts
LOC:          0   Local timer interrupts
RES:          0   Rescheduling interrupts
CAL:          0   function call interrupts
TLB:          0   TLB shootdowns
TRM:          0   Thermal event interrupts
SPU:          0   Spurious interrupts
ERR:          0
MIS:          0
Aber wie kann ich die IRQ in Debian umverteilen. Im BIOS scheint es nicht möglich zu sein.
"Fleischessen ist ein Überbleibsel der größten Rohheit. Der Übergang zum Vegetarismus ist die erste und natürlichste Folge der Aufklärung."

Lew Tolstoi

Benutzeravatar
niels
Site Admin
Beiträge: 2260
Registriert: Freitag 22. März 2002, 16:15
PLZ: 37075
voller Name: Niels Dettenbach
Wohnort: Göttingen
Kontaktdaten:

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von niels » Dienstag 28. April 2009, 15:21

Ja,
denn die Zuordnung der IRQs ändert sich nicht durch das Abziehen der Kabel.

Es wäre möglich gewesen, das der I/O durch Netwerk oder USB "zu viel Arbeit" verursacht.

Benutzeravatar
FENRIS
häufiger Besucher
Beiträge: 75
Registriert: Freitag 5. Mai 2006, 14:23
PLZ: 37351

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von FENRIS » Dienstag 28. April 2009, 15:53

Code: Alles auswählen

ifconfig eth0 irq 6
Zeigt leider keine Wirkung.

Ich habe auch acpi geaktiviert und auch den Systemdienst deaktiviert. Jetzt habe ich wieder eth0 auf 11 und dort eine vierfachbelegung-

Beim Booten kommt die Meldung

Code: Alles auswählen

Starting Hardware abstraction.layer hald [36.222533] serial8250: toomuch work for IRQ 11
[36.360053] serial8250: toomuch work for IRQ 11
[36.360964] serial8250: toomuch work for IRQ 11
[36.677897] Clocksource tcs unstable (delta= 64001027 ns) 
Hier die gesamte dmseg-Ausgabe:

Code: Alles auswählen

[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 2.6.26-2-686 (Debian 2.6.26-15) (dannf@debian.org) (gcc version 4.1.3 20080704 (prerelease) (Debian 4.1.2-25)) #1 SMP Thu Mar 26 01:08:11 UTC 2009
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[    0.000000]  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000003e000000 (usable)
[    0.000000]  BIOS-e820: 00000000ffee0000 - 00000000fff00000 (reserved)
[    0.000000]  BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
[    0.000000] 96MB HIGHMEM available.
[    0.000000] 896MB LOWMEM available.
[    0.000000] Entering add_active_range(0, 0, 253952) 0 entries of 256 used
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA             0 ->     4096
[    0.000000]   Normal       4096 ->   229376
[    0.000000]   HighMem    229376 ->   253952
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0:        0 ->   253952
[    0.000000] On node 0 totalpages: 253952
[    0.000000]   DMA zone: 32 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 4064 pages, LIFO batch:0
[    0.000000]   Normal zone: 1760 pages used for memmap
[    0.000000]   Normal zone: 223520 pages, LIFO batch:31
[    0.000000]   HighMem zone: 192 pages used for memmap
[    0.000000]   HighMem zone: 24384 pages, LIFO batch:3
[    0.000000]   Movable zone: 0 pages used for memmap
[    0.000000] DMI 2.3 present.
[    0.000000] ACPI Error (tbxfroot-0218): A valid RSDP was not found [20080321]
[    0.000000] Allocating PCI resources starting at 40000000 (gap: 3e000000:c1ee0000)
[    0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
[    0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
[    0.000000] PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
[    0.000000] SMP: Allowing 0 CPUs, 0 hotplug CPUs
[    0.000000] PERCPU: Allocating 37960 bytes of per cpu data
[    0.000000] NR_CPUS: 8, nr_cpu_ids: 1
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 251968
[    0.000000] Kernel command line: root=/dev/hda6 ro vga=normal 
[    0.000000] Local APIC disabled by BIOS -- you can enable it with "lapic"
[    0.000000] mapped APIC to ffffb000 (017cf000)
[    0.000000] Enabling fast FPU save and restore... done.
[    0.000000] Enabling unmasked SIMD FPU exception support... done.
[    0.000000] Initializing CPU#0
[    0.000000] PID hash table entries: 4096 (order: 12, 16384 bytes)
[    0.000000] Detected 1300.054 MHz processor.
[    0.004000] Console: colour VGA+ 80x25
[    0.004000] console [tty0] enabled
[    0.004000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.004000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.004000] Memory: 996104k/1015808k available (1769k kernel code, 19080k reserved, 752k data, 244k init, 98304k highmem)
[    0.004000] virtual kernel memory layout:
[    0.004000]     fixmap  : 0xfff4c000 - 0xfffff000   ( 716 kB)
[    0.004000]     pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
[    0.004000]     vmalloc : 0xf8800000 - 0xff7fe000   ( 111 MB)
[    0.004000]     lowmem  : 0xc0000000 - 0xf8000000   ( 896 MB)
[    0.004000]       .init : 0xc037f000 - 0xc03bc000   ( 244 kB)
[    0.004000]       .data : 0xc02ba4eb - 0xc0376620   ( 752 kB)
[    0.004000]       .text : 0xc0100000 - 0xc02ba4eb   (1769 kB)
[    0.004000] Checking if this processor honours the WP bit even in supervisor mode...Ok.
[    0.004000] CPA: page pool initialized 1 of 1 pages preallocated
[    0.084198] Calibrating delay using timer specific routine.. 2602.49 BogoMIPS (lpj=5204998)
[    0.084396] Security Framework initialized
[    0.084473] SELinux:  Disabled at boot.
[    0.084539] Capability LSM initialized
[    0.084631] Mount-cache hash table entries: 512
[    0.085039] Initializing cgroup subsys ns
[    0.085114] Initializing cgroup subsys cpuacct
[    0.085179] Initializing cgroup subsys devices
[    0.085280] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[    0.085355] CPU: L2 Cache: 64K (64 bytes/line)
[    0.085423] Intel machine check architecture supported.
[    0.085491] Intel machine check reporting enabled on CPU#0.
[    0.085590] Checking 'hlt' instruction... OK.
[    0.100568] SMP alternatives: switching to UP code
[    0.110932] Freeing SMP alternatives: 16k freed
[    0.111010] ACPI: Core revision 20080321
[    0.111192] ACPI Exception (tbxface-0629): AE_NO_ACPI_TABLES, While loading namespace from ACPI tables [20080321]
[    0.111354] ACPI: Unable to load the System Description Tables
[    0.111585] weird, boot CPU (#0) not listedby the BIOS.
[    0.111653] SMP motherboard not detected.
[    0.111717] Local APIC not detected. Using dummy APIC emulation.
[    0.111786] SMP disabled
[    0.111964] Brought up 1 CPUs
[    0.112007] Total of 1 processors activated (2602.49 BogoMIPS).
[    0.112007] CPU0 attaching sched-domain:
[    0.112007]  domain 0: span 0
[    0.112007]   groups: 0
[    0.112556] net_namespace: 660 bytes
[    0.112640] Booting paravirtualized kernel on bare hardware
[    0.113229] NET: Registered protocol family 16
[    0.115864] PCI: PCI BIOS revision 2.10 entry at 0xfdb01, last bus=2
[    0.115958] Setting up standard PCI resources
[    0.118520] ACPI: Interpreter disabled.
[    0.118601] Linux Plug and Play Support v0.97 (c) Adam Belay
[    0.118737] pnp: PnP ACPI: disabled
[    0.118804] PnPBIOS: Scanning system for PnP BIOS support...
[    0.118946] PnPBIOS: Found PnP BIOS installation structure at 0xc00f72c0
[    0.119020] PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0x5fcb, dseg 0xf0000
[    0.120535] PnPBIOS: 12 nodes reported by PnP BIOS; 12 recorded by driver
[    0.121198] PCI: Probing PCI hardware
[    0.121271] PCI: Probing PCI hardware (bus 00)
[    0.121597] pci 0000:00:02.0: Enabling SiS 96x SMBus
[    0.123632] PCI: Using IRQ router SIS [1039/0962] at 0000:00:02.0
[    0.123746] PCI: setting IRQ 11 as level-triggered
[    0.123751] PCI: Found IRQ 11 for device 0000:00:02.1
[    0.123842] PCI: Sharing IRQ 11 with 0000:00:09.0
[    0.124699] system 00:01: iomem range 0x0-0x9fbff could not be reserved
[    0.124788] system 00:01: iomem range 0x9fc00-0x9ffff could not be reserved
[    0.124862] system 00:01: iomem range 0xf0000-0xfffff could not be reserved
[    0.124936] system 00:01: iomem range 0x100000-0x3dffffff could not be reserved
[    0.125029] system 00:01: iomem range 0xffee0000-0xffefffff could not be reserved
[    0.125121] system 00:01: iomem range 0xfffc0000-0xffffffff could not be reserved
[    0.126160] PCI: Bridge: 0000:00:01.0
[    0.126239]   IO window: a000-afff
[    0.126305]   MEM window: 0xcfd00000-0xcfefffff
[    0.126372]   PREFETCH window: 0x00000000bfa00000-0x00000000cfbfffff
[    0.126528] NET: Registered protocol family 2
[    0.126814] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.127686] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
[    0.131882] TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
[    0.134174] TCP: Hash tables configured (established 131072 bind 65536)
[    0.134255] TCP reno registered
[    0.134583] NET: Registered protocol family 1
[    0.134907] checking if image is initramfs... it is
[    1.039694] Freeing initrd memory: 7033k freed
[    1.041121] audit: initializing netlink socket (disabled)
[    1.041237] type=2000 audit(1240932227.040:1): initialized
[    1.041631] highmem bounce pool size: 64 pages
[    1.041714] Total HugeTLB memory allocated, 0
[    1.041938] VFS: Disk quotas dquot_6.5.1
[    1.042060] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    1.042217] msgmni has been set to 1767
[    1.042641] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    1.042745] io scheduler noop registered
[    1.042808] io scheduler anticipatory registered
[    1.042873] io scheduler deadline registered
[    1.042953] io scheduler cfq registered (default)
[    1.043127] pci 0000:01:00.0: Boot video device
[    1.043748] isapnp: Scanning for PnP cards...
[    1.397848] isapnp: No Plug & Play device found
[    1.402656] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[    1.403635] PCI: Found IRQ 11 for device 0000:00:09.0
[    1.403727] PCI: Sharing IRQ 11 with 0000:00:02.1
[    1.405858] 0000:00:09.0: ttyS0 at I/O 0xd028 (irq = 11) is a 8250
[    1.406469] 0000:00:09.0: ttyS1 at I/O 0xd040 (irq = 11) is a 8250
[    1.406919] 0000:00:09.0: ttyS2 at I/O 0xd050 (irq = 11) is a 8250
[    1.407385] 0000:00:09.0: ttyS3 at I/O 0xd060 (irq = 11) is a 8250
[    1.407551] Couldn't register serial port 0000:00:09.0: -28
[    1.410324] brd: module loaded
[    1.410634] PNP: PS/2 Controller [PNP0303,PNP0f13] at 0x60,0x64 irq 1,12
[    1.411108] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.411187] serio: i8042 AUX port at 0x60,0x64 irq 12
[    1.411574] mice: PS/2 mouse device common for all mice
[    1.411955] rtc_cmos 00:05: rtc core: registered rtc_cmos as rtc0
[    1.412101] rtc0: alarms up to one day
[    1.412253] cpuidle: using governor ladder
[    1.412318] cpuidle: using governor menu
[    1.412388] No iBFT detected.
[    1.413207] TCP cubic registered
[    1.413271] NET: Registered protocol family 17
[    1.413346] Using IPI No-Shortcut mode
[    1.413769] registered taskstats version 1
[    1.414072] rtc_cmos 00:05: setting system clock to 2009-04-28 15:23:48 UTC (1240932228)
[    1.414888] Freeing unused kernel memory: 244k freed
[    1.437596] input: AT Translated Set 2 keyboard as /class/input/input0
[    1.700155] thermal: Unknown symbol acpi_processor_set_thermal_limit
[    2.517597] Uniform Multi-Platform E-IDE driver
[    2.517686] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
[    2.532473] SIS5513: SiS 962/963 MuTIOL IDE UDMA133 controller
[    2.532563] SIS5513: IDE controller (0x1039:0x5513 rev 0x00) at  PCI slot 0000:00:02.5
[    2.532669] SIS5513: not 100% native mode: will probe irqs later
[    2.532758]     ide0: BM-DMA at 0xff00-0xff07
[    2.532840]     ide1: BM-DMA at 0xff08-0xff0f
[    2.532913] Probing IDE interface ide0...
[    2.596648] usbcore: registered new interface driver usbfs
[    2.596792] usbcore: registered new interface driver hub
[    2.596918] usbcore: registered new device driver usb
[    2.607323] ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
[    2.628421] sis900.c: v1.08.10 Apr. 2 2006
[    2.820415] hda: ExcelStor Technology J880, ATA DISK drive
[    3.100349] hdb: WDC WD1600AAJB-56WRA0, ATA DISK drive
[    3.156277] hda: host max PIO4 wanted PIO255(auto-tune) selected PIO4
[    3.156439] hda: UDMA/133 mode selected
[    3.156637] hdb: host max PIO4 wanted PIO255(auto-tune) selected PIO4
[    3.156731] hdb: UDMA/100 mode selected
[    3.156867] Probing IDE interface ide1...
[    3.892417] hdc: TSSTcorpCD/DVDW TS-H552U, ATAPI CD/DVD-ROM drive
[    4.564340] hdc: host max PIO4 wanted PIO255(auto-tune) selected PIO4
[    4.564461] hdc: UDMA/33 mode selected
[    4.565374] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[    4.565541] ide1 at 0x170-0x177,0x376 on irq 15
[    4.565996] PCI: Found IRQ 11 for device 0000:00:03.0
[    4.566127] ohci_hcd 0000:00:03.0: OHCI Host Controller
[    4.566430] ohci_hcd 0000:00:03.0: new USB bus registered, assigned bus number 1
[    4.566562] ohci_hcd 0000:00:03.0: irq 11, io mem 0xcfffa000
[    4.622462] usb usb1: configuration #1 chosen from 1 choice
[    4.622598] hub 1-0:1.0: USB hub found
[    4.622685] hub 1-0:1.0: 3 ports detected
[    4.724491] usb usb1: New USB device found, idVendor=1d6b, idProduct=0001
[    4.724576] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.724667] usb usb1: Product: OHCI Host Controller
[    4.724732] usb usb1: Manufacturer: Linux 2.6.26-2-686 ohci_hcd
[    4.724801] usb usb1: SerialNumber: 0000:00:03.0
[    4.724952] PCI: Found IRQ 11 for device 0000:00:03.1
[    4.725083] ohci_hcd 0000:00:03.1: OHCI Host Controller
[    4.725214] ohci_hcd 0000:00:03.1: new USB bus registered, assigned bus number 2
[    4.725334] ohci_hcd 0000:00:03.1: irq 11, io mem 0xcfffb000
[    4.782442] usb usb2: configuration #1 chosen from 1 choice
[    4.782582] hub 2-0:1.0: USB hub found
[    4.782670] hub 2-0:1.0: 3 ports detected
[    4.884489] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[    4.884576] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    4.884667] usb usb2: Product: OHCI Host Controller
[    4.884732] usb usb2: Manufacturer: Linux 2.6.26-2-686 ohci_hcd
[    4.884800] usb usb2: SerialNumber: 0000:00:03.1
[    4.884966] PCI: setting IRQ 5 as level-triggered
[    4.884972] PCI: Found IRQ 5 for device 0000:00:03.3
[    4.885102] ehci_hcd 0000:00:03.3: EHCI Host Controller
[    4.885226] ehci_hcd 0000:00:03.3: new USB bus registered, assigned bus number 3
[    4.885398] PCI: cache line size of 64 is not supported by device 0000:00:03.3
[    4.885418] ehci_hcd 0000:00:03.3: irq 5, io mem 0xcffdf000
[    5.028268] usb 1-1: new full speed USB device using ohci_hcd and address 2
[    5.040275] ehci_hcd 0000:00:03.3: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[    5.040554] usb usb3: configuration #1 chosen from 1 choice
[    5.040681] hub 3-0:1.0: USB hub found
[    5.040764] hub 3-0:1.0: 6 ports detected
[    5.096303] hub 1-0:1.0: unable to enumerate USB device on port 1
[    5.144522] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002
[    5.144604] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.144694] usb usb3: Product: EHCI Host Controller
[    5.144759] usb usb3: Manufacturer: Linux 2.6.26-2-686 ehci_hcd
[    5.144828] usb usb3: SerialNumber: 0000:00:03.3
[    5.144981] PCI: Found IRQ 11 for device 0000:00:04.0
[    5.146368] 0000:00:04.0: VIA 6103 PHY transceiver found at address 1.
[    5.159301] 0000:00:04.0: Using transceiver found at address 1 as default
[    5.160678] eth0: SiS 900 PCI Fast Ethernet at 0xd400, IRQ 11, 00:0d:87:5b:52:c0
[    5.181542] SCSI subsystem initialized
[    5.200138] libata version 3.00 loaded.
[    5.337937] hda: max request size: 512KiB
[    5.348153] hda: 160836480 sectors (82348 MB) w/1719KiB Cache, CHS=16383/255/63
[    5.352402] hda: cache flushes supported
[    5.352581]  hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 hda8 >
[    5.412097] hdb: max request size: 512KiB
[    5.427579] hdb: 312581808 sectors (160041 MB) w/8192KiB Cache, CHS=19457/255/63
[    5.427872] hdb: cache flushes supported
[    5.428047]  hdb: hdb1
[    5.448419] hdc: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache
[    5.448691] Uniform CD-ROM driver Revision: 3.20
[    6.195267] PM: Starting manual resume from disk
[    6.276988] kjournald starting.  Commit interval 5 seconds
[    6.277103] EXT3-fs: mounted filesystem with ordered data mode.
[    6.508386] usb 1-1: new full speed USB device using ohci_hcd and address 3
[    6.713147] usb 1-1: configuration #1 chosen from 1 choice
[    6.715358] hub 1-1:1.0: USB hub found
[    6.718260] hub 1-1:1.0: 4 ports detected
[    6.836611] usb 1-1: New USB device found, idVendor=03eb, idProduct=0902
[    6.836699] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    7.140419] usb 1-2: new full speed USB device using ohci_hcd and address 4
[    7.353475] usb 1-2: configuration #1 chosen from 1 choice
[    7.356729] usb 1-2: New USB device found, idVendor=04a9, idProduct=220d
[    7.356818] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    7.356893] usb 1-2: Product: CanoScan
[    7.356953] usb 1-2: Manufacturer: Canon
[    7.660452] usb 2-2: new full speed USB device using ohci_hcd and address 2
[    7.876422] usb 2-2: configuration #1 chosen from 1 choice
[    7.879597] usb 2-2: New USB device found, idVendor=03f0, idProduct=0c17
[    7.879684] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    7.879759] usb 2-2: Product: hp LaserJet 1010
[    7.879823] usb 2-2: Manufacturer: Hewlett-Packard
[    7.879887] usb 2-2: SerialNumber: 00CNFF433210
[    8.274213] udevd version 125 started
[   10.403157] Linux agpgart interface v0.103
[   10.429155] agpgart: Detected SiS chipset - id:1856
[   10.435674] agpgart: AGP aperture is 64M @ 0xd0000000
[   10.449478] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   10.462936] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   10.485489] sis96x_smbus 0000:00:02.1: SiS96x SMBus base address: 0x0c00
[   11.120716] usblp0: USB Bidirectional printer dev 2 if 0 alt 1 proto 2 vid 0x03F0 pid 0x0C17
[   11.120861] usbcore: registered new interface driver usblp
[   11.330270] input: PC Speaker as /class/input/input1
[   11.797061] logips2pp: Detected unknown logitech mouse model 105
[   12.011897] gameport: NS558 PnP Gameport is pnp00:09/gameport0, io 0x201, speed 573kHz
[   12.269296] input: ImExPS/2 Logitech Explorer Mouse as /class/input/input2
[   12.660397] PCI: Found IRQ 11 for device 0000:00:02.7
[   12.980758] intel8x0_measure_ac97_clock: measured 55658 usecs
[   12.980843] intel8x0: clocking to 48000
[   13.849305] Adding 979924k swap on /dev/hda5.  Priority:-1 extents:1 across:979924k
[   14.313262] EXT3 FS on hda6, internal journal
[   14.726455] loop: module loaded
[   14.832989] device-mapper: uevent: version 1.0.3
[   14.833202] device-mapper: ioctl: 4.13.0-ioctl (2007-10-18) initialised: dm-devel@redhat.com
[   16.252664] kjournald starting.  Commit interval 5 seconds
[   16.252958] EXT3 FS on hda8, internal journal
[   16.253061] EXT3-fs: mounted filesystem with ordered data mode.
[   16.275503] kjournald starting.  Commit interval 5 seconds
[   16.275983] EXT3 FS on hdb1, internal journal
[   16.276085] EXT3-fs: mounted filesystem with ordered data mode.
[   20.241865] eth0: Media Link On 100mbps full-duplex 
[   23.283942] NET: Registered protocol family 10
[   23.284804] lo: Disabled Privacy Extensions
[   30.689275] powernow_k7: Unknown symbol acpi_processor_notify_smm
[   30.689462] powernow_k7: Unknown symbol acpi_processor_unregister_performance
[   30.689796] powernow_k7: Unknown symbol acpi_processor_register_performance
[   30.709436] acpi_cpufreq: Unknown symbol acpi_processor_notify_smm
[   30.709703] acpi_cpufreq: Unknown symbol acpi_processor_unregister_performance
[   30.710127] acpi_cpufreq: Unknown symbol acpi_processor_preregister_performance
[   30.710351] acpi_cpufreq: Unknown symbol acpi_processor_register_performance
[   31.975767] lp: driver loaded but no devices found
[   32.012772] ppdev: user-space parallel port driver
[   33.969756] eth0: no IPv6 routers present
[   36.222533] serial8250: too much work for irq11
[   36.360053] serial8250: too much work for irq11
[   36.360964] serial8250: too much work for irq11
[   36.677897] Clocksource tsc unstable (delta = 64001027 ns)
"Fleischessen ist ein Überbleibsel der größten Rohheit. Der Übergang zum Vegetarismus ist die erste und natürlichste Folge der Aufklärung."

Lew Tolstoi

Benutzeravatar
niels
Site Admin
Beiträge: 2260
Registriert: Freitag 22. März 2002, 16:15
PLZ: 37075
voller Name: Niels Dettenbach
Wohnort: Göttingen
Kontaktdaten:

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von niels » Dienstag 28. April 2009, 16:51

FENRIS hat geschrieben:

Code: Alles auswählen

Starting Hardware abstraction.layer hald [36.222533] serial8250: toomuch work for IRQ 11
[36.360053] serial8250: toomuch work for IRQ 11
[36.360964] serial8250: toomuch work for IRQ 11
[36.677897] Clocksource tcs unstable (delta= 64001027 ns) 
Sorry,
serial8250 ist die serielle Schnittstelle. Brauchst Du die? Wenn nicht - > im BIOS auch mal ausmachen.

Was sagt ein:

Code: Alles auswählen

cat /proc/tty/driver/serial 
?
Hast Du auch mal apic deaktiviert?

In jedem Fall solltest Du die IRQs umräumen und unnötige Hardware soweit möglich schon im BIOS ausmachen - geht das nicht, die (hoffentlich bei Dir als Modul verfügbaren) Treiber per blacklist beim Booten vom Laden sperren.


fand nebenbei folgendes Zitat aus 2005:
Yes, when I studied UART's years ago (to get linux working with the
serial hardware on my just purchased, used 386 motherboard - that was
back in Cincinnati I'm sure, so it would have been over 11 years ago),
8250's were ancient, and 16550A's were hot stuff. If this server
literally has 8250's, then this rather poor serial hardware.

Benutzeravatar
FENRIS
häufiger Besucher
Beiträge: 75
Registriert: Freitag 5. Mai 2006, 14:23
PLZ: 37351

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von FENRIS » Dienstag 28. April 2009, 17:30

cat /proc/tty/driver/serial gibt aus:

Code: Alles auswählen

serinfo:1.0 driver revision:
0: uart:8250 port:0000D028 irq:11 tx:0 rx:0
1: uart:8250 port:0000D040 irq:11 tx:0 rx:0
2: uart:8250 port:0000D050 irq:11 tx:0 rx:0
3: uart:8250 port:0000D060 irq:11 tx:0 rx:0
Ich habe ACPI im BIOS und beim Booten abgestellt. APIC beim Booten.

Es kommt zwar zu keiner Fehlermeldung mehr beim Booten, aber die IRQ-Verteilung ist unverändert.

DIe serielle Schnittstelle hatte ich vorher schon im BIOS deaktiviert, verstehe nicht warum die da immer noch drinne ist
"Fleischessen ist ein Überbleibsel der größten Rohheit. Der Übergang zum Vegetarismus ist die erste und natürlichste Folge der Aufklärung."

Lew Tolstoi

Benutzeravatar
niels
Site Admin
Beiträge: 2260
Registriert: Freitag 22. März 2002, 16:15
PLZ: 37075
voller Name: Niels Dettenbach
Wohnort: Göttingen
Kontaktdaten:

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von niels » Mittwoch 29. April 2009, 16:29

DIe serielle Schnittstelle hatte ich vorher schon im BIOS deaktiviert, verstehe nicht warum die da immer noch drinne ist
Hmmm,
kann z.B. sein, das Du einen UART irgendwo auf dem Board hast, der nicht per BIOS deaktivierbar ist (manchmal kann man nur einen COM-Port abschalten und nicht alle COM-Ports müssen auch am Gehäuse nach außen geführt sein).

Dann versuch mal das Treibermodul beim Booten nicht automatisch laden zu lassen:

Code: Alles auswählen

blacklist serial8250
indem Du in der Modulkonfiguration - je nach Distribution z.B. in
/etc/modprobe.d/... oder
/etc/modules.conf
/etc/modprobe.conf

setzt.

Achtung:
Bei vielen moderneren Distributionen wird die modprobe.conf oder modules.conf automatisch durch den Befehl "update-modules" erstellt un Deine Änderungen dort somit überschrieben (oft schon beim nächsten Boot). Üblicherweise steht dann am Anfang der genannten Konfigurationsdateien der Ort bzw. eine Beschreibung, wo man seine Konfigurationen unterzubringen hat, damit sie dauerhaft sind.

Schau dann mit

Code: Alles auswählen

lsmod |grep serial
ob das Modul noch geladen wird. Alternativ probier mal ein:

Code: Alles auswählen

rmmod serial8250
um den Treiber zu entladen.

Hast Du sonst irgendwelche Probleme, die sich in dem Zusammenhang bemerkbar machen oder geht Dir nur die Fehlermeldung auf den Keks?

viel Glück,

Niels.

Benutzeravatar
niels
Site Admin
Beiträge: 2260
Registriert: Freitag 22. März 2002, 16:15
PLZ: 37075
voller Name: Niels Dettenbach
Wohnort: Göttingen
Kontaktdaten:

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von niels » Freitag 1. Mai 2009, 13:58

hallo nochmal,

Sorry, aber das habe ich vom Handy aus wohl überlesen:
FENRIS hat geschrieben:

Code: Alles auswählen

Plug and Play Aware O/S:   [b]YES [/b]  NO
Primary Graphic Adapter: [b]PCI[/b] AGP
Allocate IRQ to PCI VGA: [b]YES[/b] NO
PCI IDE BusMaster: [b]DISABLED[/b] ENABLED
Üblicherweise sollte man das so machen / versuchen:
PnP: NO
pCI IDE Busmaster: ENABLED

graphic Adapter und IRQ nur, wenn es ein PCI (kein AGP) Adapter ist. Kannst Du ggf. mit lspci ermitteln.

[/quote]
Wo werden eigentlich die IRQ zu geteilt über das BIOS oder kann mensch da auch was über das OS machen.
[/quote]
Wie schon in meinen Tips beschrieben: IRQs entweder per BIOS oder per OS setzen lassen. Je nach Geräten kann dies im BIOS, per Moduloptionen oder per ACPI / APIC erfolgen.

Benutzeravatar
FENRIS
häufiger Besucher
Beiträge: 75
Registriert: Freitag 5. Mai 2006, 14:23
PLZ: 37351

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von FENRIS » Mittwoch 13. Mai 2009, 12:06

Dabke nochmal für deine Antowort. Ich hatte bisher keine Ziet zu antworten.

Ich habe zwar den Treiber in die Blacklist eingetragen. Es hat aber keine Wirkung.
niels hat geschrieben:hallo nochmal,

graphic Adapter und IRQ nur, wenn es ein PCI (kein AGP) Adapter ist. Kannst Du ggf. mit lspci ermitteln.
Das Liefert mir folgendes Ergebnis:

Code: Alles auswählen

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 740 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:09.0 Modem: ALi Corporation SmartLink SmartPCI561 56K Modem
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter
Das ist etwas verwirrend, aber ich denke das der Adapter wohl AGP ist. Und habe dass im BIOS entsprechend geändert.

LG FENRIS
"Fleischessen ist ein Überbleibsel der größten Rohheit. Der Übergang zum Vegetarismus ist die erste und natürlichste Folge der Aufklärung."

Lew Tolstoi

Benutzeravatar
niels
Site Admin
Beiträge: 2260
Registriert: Freitag 22. März 2002, 16:15
PLZ: 37075
voller Name: Niels Dettenbach
Wohnort: Göttingen
Kontaktdaten:

Re: Zu viel Arbeit für IRQ 11

Ungelesener Beitrag von niels » Dienstag 19. Mai 2009, 14:58

Hast Du sonst irgendwelche Probleme, die sich in dem Zusammenhang bemerkbar machen oder geht Dir nur die Fehlermeldung auf den Keks?
???

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 29 Gäste